Author Topic: Trigger multiple active son  (Read 561 times)

tpt

  • Apprenti poseur de brushs
  • Posts: 66
Trigger multiple active son
« on: September 08, 2010, 07:40:57 PM »
Salut

j'ai fait un trigger_multiple avec un setthread pour activé le thread d'un son mais j'ai un souci. Dès que je touche le trigger le son s'active en boucle, or j'aimerai qu'il ne s'active qu'une seule fois tant que je suis dans le trigger(je précise que j'utilise bien la commande playsound) et ce n'est qu'en m'enlevant et en revenant sur le trigger qu'il faudrai que le son soit relancé une seule fois, ainsi de suite...

 

eric30

  • Bleusaille
  • Posts: 11
Trigger multiple active son
« Reply #1 on: September 08, 2010, 10:15:01 PM »
En fait il faut que tu fasses un autre trigger qui rejoue le son par défaut à la sortie de la zone du premier trigger. Je m'explique:

Imaginons que tu aies ta map avec un son d'ambiance, par exemple combat dans le lointain. Tu veux que quand tu rentres dans une pièce, un son se joue, mais quand tu en ressort, le son de départ revienne.

Il te faut donc au moins* deux triggers: un pour activer le son de la pièce, un pour remettre le son de départ.

* Je dis deux, mais plus selon le nombre d'accès.
De retour au mapping après 5 années de vacances. Dure dure la reprise...

tpt

  • Apprenti poseur de brushs
  • Posts: 66
Trigger multiple active son
« Reply #2 on: September 09, 2010, 03:14:12 PM »
il faut également que le son dans la pièce ne soit joué q'une seule fois et non en boucle j'ai un doute sur le fonctionnement de cet méthode

tpt

  • Apprenti poseur de brushs
  • Posts: 66
Trigger multiple active son
« Reply #3 on: September 09, 2010, 07:53:41 PM »
Finalement j'ai trouvé un moyen qui à l'air de fonctionné, en mettant un loopsound et stoploopsound au bout d'une seconde mais j'ai quand même l'impression que le son tourne en boucle, sauf qu'il ne s'entend pas à cause d'un semblant de lag.  :huh: